SixXS::Sunset 2017-06-06

Problems with AICCU and static tunnel
[dk] Shadow Hawkins on Friday, 03 August 2007 18:02:06
I downloaded the latest version of AICCU from: Which I installed on my Debian Etch machine without problems. I am behind a NAT router, but I have redirected all traffic from the router to my Linux machine, so I assumed I could use a static tunnel by enabling the option local_ipv4_override in /etc/aiccu.conf and opening for protocol 41 in my firewall. However, this gave me the following error on startup of AICCU: Unknown configuration statement on line 79 of /etc/aiccu.conf: "local_ipv4_overrid" No, this is not a spelling mistake. The last letter 'e' was missing. I tried moving the line around, making sure there wasn't a problem with newline characters, etc. but to no avail. I tried adding an additional 'e' so the line in /etc/aiccu.conf read: local_ipv4_overridee And now the client didn't complain about the line anymore. Now I got an error about the local address "remote" not being a valid IPv4 address. I changed my tunnel to a Heartbeat tunnel so I didn't need the "local_ipv4_override" option, but after some testing I discovered that my router does not forward protocol 41 to the "Default server" even though ZyXEL support claims that it does. I finally changed my tunnel to AYIYA and now everything works... except that with my current credit balance it will take months before I can get subnet and actually start using my IPv6 connection :) Anyway... my question is if anyone has experienced this behaviour with AICCU (the "local_ipv4_override" option not working)? Regards, Michael
Problems with AICCU and static tunnel
[ch] Jeroen Massar SixXS Staff on Friday, 03 August 2007 20:36:29
The option needs to be specified as "local_ipv4_override" but then with your PUBLIC IPv4 address. Just ignoring this option though works fine too. ZyXEL's are known to not forward protocol 41 even when in DMZ mode, at least from various sources that I heard that of. AYIYA is the solution in most cases, that is why it exists.
Problems with AICCU and static tunnel
[dk] Shadow Hawkins on Friday, 03 August 2007 22:26:32
Thanks a lot for your reply. Now it makes sense about that option. And consider this another source confirming that ZyXEL does not forward protocol 41 in DMZ mode. At least not their P-2602HW-D1A router.

Please note Posting is only allowed when you are logged in.

Static Sunset Edition of SixXS
©2001-2017 SixXS - IPv6 Deployment & Tunnel Broker