SixXS::Sunset 2017-06-06

AICCU and Go6 (FreeNet6/Hexago) ?
[ca] Carmen Sandiego on Friday, 16 March 2007 00:11:48
Hi there folks :) .. Have been using SixXS since forever, and love the AICCU client, but I am trying to help a friend (and teach myself in the process) how he can set up his IPv6 using the Go6 tunnelbroker.. And I notice on the "Supported brokers" list on the AICCU page that it fully supports FreeNet6 and the TSP protocol.. But I am having trouble making it work :( It seems to just hang once I try to run the program. This is an Ubuntu EDGY installation :) Here is what my /etc/aiccu.conf looks like
root@hive-laptop:/etc# cat aiccu.conf # AICCU Configuration # Login information (defaults: none) username MYUSER password MYPA$$WORD # Protocol and server to use for setting up the tunnel (defaults: none) protocol tsp server # Interface names to use (default: aiccu) # ipv6_interface is the name of the interface that will be used as a tunnel interface. # On *BSD the ipv6_interface should be set to gifX (eg gif0) for proto-41 tunnels # or tunX (eg tun0) for AYIYA tunnels. ipv6_interface tb # The tunnel_id to use (default: none) # (only required when there are multiple tunnels in the list) #tunnel_id Txxxx # Be verbose? (default: false) verbose true # Daemonize? (default: true) # Set to false if you want to see any output # When true output goes to syslog # # WARNING: never run AICCU from DaemonTools or a similar automated # 'restart' tool/script. When AICCU does not start, it has a reason # not to start which it gives on either the stdout or in the (sys)log # file. The TIC server *will* automatically disable accounts which # are detected to run in this mode. # daemonize false # Automatic Login and Tunnel activation? automatic true # Require TLS? # When set to true, if TLS is not supported on the server # the TIC transaction will fail. # When set to false, it will try a starttls, when that is # not supported it will continue. # In any case if AICCU is build with TLS support it will # try to do a 'starttls' to the TIC server to see if that # is supported. requiretls false # PID File #pidfile /var/run/ # Add a default route (default: true) #defaultroute true # Script to run after setting up the interfaces (default: none) #setupscript /usr/local/etc/ # Make heartbeats (default true) # In general you don't want to turn this off # Of course only applies to AYIYA and heartbeat tunnels not to static ones #makebeats true # Don't configure anything (default: false) #noconfigure true # Behind NAT (default: false) # Notify the user that a NAT-kind network is detected #behindnat true # Local IPv4 Override (default: none) # Overrides the IPv4 parameter received from TIC # This allows one to configure a NAT into "DMZ" mode and then # forwarding the proto-41 packets to an internal host. # # This is only needed for static proto-41 tunnels! # AYIYA and heartbeat tunnels don't require this. #local_ipv4_override root@hive-laptop:/etc#
So I don't see anything glaringly obvious I did wrong there; I tried prefixing the tunnel broker with tsp:// but it was taken literally and couldn't resolve the hostname.. All that happens once I run it is
root@hive-laptop:/etc# aiccu start ( 5 minutes elapse and I just CTRL+C to exit )
No output at all, and I've let it sit for a long time.. I tried a few other various things like commenting out the 'protocol tsp' line and what not, but the results stayed the same I much prefer AICCU than the tspc-client that FreeNet6 provides so if anyone has any ideas it would be much appreciated :) Thanks folks
AICCU and Go6 (FreeNet6/Hexago) ?
[ch] Jeroen Massar SixXS Staff on Friday, 16 March 2007 00:30:42
Unfortunately AICCU doesn't support TSP yet in the public releases. As per the history page: 8<------------------------------------------------------ Future Updates / Wishlist / Known bugs and issues .... * TSP (Tunnel Setup Protocol) Support [experimental, no demand, thus low priority]. ------------------------------------------------------->8 We have experimental versions of it that work, more or less and as far as we could test, similarly there is a TSP server for SixXS. Both are not publically available as we deemed them too experimental and rather only have fully working and supported tools out. As time is quite limited on our side at the moment and for the coming couple of months there won't be an effort soon to fix this up either. As for the no-output, with "daemonize false" and "verbose true" you should at least get the intro line and a lot of other debug output. PS: when reporting problems with programs, do please note the version number next to who compiled it.

Please note Posting is only allowed when you are logged in.

Static Sunset Edition of SixXS
©2001-2017 SixXS - IPv6 Deployment & Tunnel Broker