Quagga routing example

From SixXS Wiki
Jump to: navigation, search

These are example zebra & ospf6d files for use with Quagga 0.98.6 or later. If you're setting up a tinc VPN or other tunnel-based provisioning, you will need to make sure Quagga is (re)started after the VPN/tunnel software is connected, or it will never detect other member routers.

Example parameters

These example files use an example 2001:db8:1::/48 allocation, with the #0 /64 subnet used for interconnects and #1 & #2 as user subnets. 2001:db8:1::1 is considered as the "master router."

Example zebra.conf

    password whatever
    ipv6 forwarding
    ipv6 route 2001:db8:1:2::/64 br0
    interface br0
    link-detect
    no ipv6 nd suppress-ra
    ipv6 nd ra-interval 10
    ipv6 address 2001:db8:1:2::ffff/64
    ipv6 nd prefix 2001:db8:1:2::/64
    interface vpn6
    link-detect
    ipv6 address 2001:db8:1::/64
    interface lo
    link-detect

Master-router-only command to add

    ipv6 route 2000::/3 2001:db8:1::1

Example ospf6d.conf

    password whatever
    !
    !adapter setup
    !
    interface br0
    interface vpn6
    !
    !router setup
    !
    router ospf6
    router-id 0.0.0.2
    redistribute static
    redistribute connected
    area 0.0.0.2 range 2001:db8:1:2::/64
    interface br0 area 0.0.0.2
    interface vpn6 area 0.0.0.0

Example bgpd.conf

    password whatever
    !
    router bgp 64512
     bgp router-id 1.2.3.4
     ...IPv4 config, if neccessary...
     neighbor 1.2.4.4 remote-as 64513
     neighbor 1.2.5.4 remote-as 64514
    !
     address-family ipv6
     network 2001:db8:1:2::/64
     neighbor 1.2.4.4 activate
     neighbor 1.2.5.4 activate
     exit-address-family
    !